昨天晚上小蛙把「我的股票精算師」程式簽署打包好後送上android market,等了一段時間網頁版的market終於可以搜尋的到了,但是不管怎麼試,小蛙的Desire上的market就是蒐尋不到,小蛙想透過web market直接安裝在手機上,卻出現「這個項目與您的裝置不相容」,發生什麼事 … 軟體測試的時候就是在Desire上測試的,上傳之後竟然跟小蛙說裝置不相容,網路上有不少討論說新版的market起笑,常常會自己把東西莫名其妙過濾掉,看來這次小蛙真的遇到了 …

 

在遇到這件事之前,小蛙有個好朋友賴說他們遇到一個奇怪的問題,同一款手機同一個作業系統上market查同一個軟體,竟然會有一台可以正常下載,另一台卻連搜尋都看不到的情況。小蛙還沒遇過,只是覺得神奇。這次小蛙的「我的股票精算師」上架之後,竟然就遇到market搜尋不到的問題,想說會不會有可能是因為用了admob必須把SDK設定為3.2的關係導致的,也把原本支援1.6+調高成2.1+,這些設定都還是沒辦法逃脫搜尋不到的命運。

有空的時候小蛙會常逛market,看看有沒有什麼好用或好玩的軟體,現在因為台北市政府的關係,台灣地區也沒有辦法購買付費軟體了,小蛙不便發表評論,對錯參半。有時候看到有不錯的軟體想下載,卻出現「這個項目與您的裝置不相容」真的很令人惱怒,之後到「地下市場」、「黑市」、「對岸論壇」上下載(簡直是逼良為娼),卻又可以正常安裝跟使用,讓小蛙不禁想問android market真的出了問題了嗎?

令人惱怒的「這個項目與您的裝置不相容」,明明是1.6+也沒使用什麼特殊裝置,為什麼Tattoo可以,Desire就是不行。

 後來小蛙在發布後台看到一個選項,感覺開發照照明星臉的時候沒看過這選項,就把原本設定成的「開啟」改成「關閉」。

過一段時間上market上去看,原本不能用的Desire竟然也變成可以了@_@ … 真是太神奇了傑克。

另外提一個不相干的,小蛙在搜尋market的時候發現一件有趣的事情,就是明明只有一個搜尋結果,market卻出現「約有 2 項搜尋結果」,market真的怪怪的 …

/* if( /Android|webOS|iPhone|iPad|iPod|BlackBerry|IEMobile|Opera Mini/i.test(navigator.userAgent) ) { document.write('
>